Looking for Customer Service & Support

IMPORTANT: This is a Community Forum. Answers are given by the community. If you are a Customer, please, Open New Issue to get access to the support service.

Customer Support is only provided through our ticketing system https://support.extly.com/. If you do not have a paid membership, please create a new topic in the community forum.

Problems with new Facebook authorization

More
5 years 4 months ago #5383 by Ulli Storck
Ulli Storck created the topic: Problems with new Facebook authorization
Hi,

I have found a strange bug in AutoTweet code for Facebook authorization. The bug is comming up only if you use your own App. With the standard app it should work without problems.

The bug results in the following possible problems:
  • AutoTweet uses the standard App for posting instead your own app.
  • Error message when you save a channel.
  • Error message "unsupported get request".

I'm on my way to fix this problem, but I need some time at the weekend for coding and testing. I hope to release a fix on monday (July 16).

As a workaround you can use the standard app at the moment. If you have problems saving the channels (also with the standard app) please uninstall/reinstall AutoTweet.

Sorry for the inconvenience,
Ulli
The topic has been locked.
More
5 years 4 months ago #5393 by Ulli Storck
Ulli Storck replied the topic: Re: Problems with new Facebook authorization
I've done a first fix and I need your help for testing. The fix is in the authorization server files and so no new release is needed.

The fix should solve the problem with own apps. I'm not sure if it fixes alo the problem with the error when a channel is saved (My problem is that I can't reproduce this problem on my own test server).

Please note:
  • You must do a new authorization for the Facebook account and copy/paste the displayed (new) token into the field in the dialog.
  • If you use your own app, you must enter the app data and activate the own app BEFORE you press the authorization button. The token for your own app is different from the token for the standard app!
[/b]

Please report back here in this thread!

Thx a lot,
Ulli
The topic has been locked.
More
5 years 4 months ago - 5 years 4 months ago #5394 by XOOMSERVE
XOOMSERVE replied the topic: [SOLVED] Re: Problems with new Facebook APP
Hello,

Great response, support and many more.

I confirm my problem has been solved and now my APP is working great :)

Best Regards,
Tariq
Attachments:
Last Edit: 5 years 4 months ago by XOOMSERVE.
The topic has been locked.
More
5 years 4 months ago #5398 by anhel
anhel replied the topic: Re: [SOLVED] Re: Problems with new Facebook APP
I'm using the free version, but give me the error:


Error saving channel data: Can not store Channel data.

Error: Data for channel could not be saved.

Help me please.

Thanks.
The topic has been locked.
More
5 years 4 months ago #5399 by Ulli Storck
Ulli Storck replied the topic: Re: [SOLVED] Re: Problems with new Facebook APP
@anhel: Please post your Joomla and AutoTweet version.
Is this a new installation or have you updated AutoTweet? If sp from what version have you updated?
The topic has been locked.
More
5 years 4 months ago #5400 by anhel
anhel replied the topic: Re: [SOLVED] Re: Problems with new Facebook APP
I have:

AutoTweet-Component 4.12
Automator-Plugin 2.2
Content-Extension Pro 1.9
Joomla 1.5.23

Thanks.
The topic has been locked.
Time to create page: 0.111 seconds
Join the Club!

Access and support services to all Extly's extensions for 1-Year. The Extly Club is your source for all of our extensions.

Join Now