Looking for Customer Service & Support

Customer support is provided through our ticketing system. https://support.extly.com/. Otherwise, please create a new topic in the community forum.

Welcome, Guest
Username: Password: Remember me

TOPIC: ATNG: SEF URL only after second attempt

ATNG: SEF URL only after second attempt 1 year 5 months ago #5915

Hi,

I have a strange issue. After submitting article it appears in "message log" where I need it to be approve. But URL for article is not SEF (...index.php?option=com_content&view=article&id=...) and log contain:
WARNING Error routing SEF URL via frontend request - curl_error: 60 SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
I just delete this article from message log, after few minute it reappears again but this time with SEF URL. I don't get why and how this happens... :unsure:

Articles workflow: First I create and save article as Uncategirised, then final version is saved in News from where it's taken by ATNG for FB.

Site has a self signed SSL sertificate. Backend is mandatory accessed with SSL, frontend without.

Both ATNG plugins are placed after SEF plugin in Joomla.

I have added in base_facebook.php code:
CURLOPT_SSL_VERIFYPEER => false,
CURLOPT_SSL_VERIFYHOST => false,

Options: Routing: Yes, Compatible;

Setup: Joomla 2.5.8, ATNG 6.3.5, com-content, standart Joomla SEF
  • Meta Wind
  • Meta Wind's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 5
  • Karma: 0
The administrator has disabled public write access.

ATNG: SEF URL only after second attempt 1 year 5 months ago #5916

AutoTweetNG SEF router follows the same site protocol to generate the final link.

However, CURL does not accept your self-signed certificate (file administrator/components/com_autotweet/helpers/autotweetroutehelper.php).

1. When you changed base_facebook.php, you were in the right direction changing a CURL call, but it's not the right file ;) You can change autotweetsefrouter.php, line 80; to disable the verification.

2. There an alternative SEF Router, please try Advanced Settings/Routing mode/Performance

Regards,
  • Support Team
  • Support Team's Avatar
  • OFFLINE
  • Moderator
  • Posts: 1184
  • Thank you received: 95
  • Karma: 14
The administrator has disabled public write access.

ATNG: SEF URL only after second attempt 1 year 5 months ago #5923

Hi,

Is there any explanation of correct SEF URL only after second attempt as I wrote in my post?

1. I'm just following FAQ at this site - here and here is about file
administrator/components/com_autotweet/helpers/channels/facebook-php-sdk/base_facebook.php, line 137

Also I don't have autotweetsefrouter.php in administrator/components/com_autotweet/
There is such file in /components/com_autotweet/ but it's short, about 50 lines at all

2. Now the good news. Performance mode routing seems works for me - I have SEF URL today with the first attempt. Hope tomorrow will be the same. :)

Will waiting 6.4 version. ;)
  • Meta Wind
  • Meta Wind's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 5
  • Karma: 0
The administrator has disabled public write access.

ATNG: SEF URL only after second attempt 1 year 5 months ago #5924

1. The FAQ about Facebook is to solve a different subject.

The files related with your issue are:

administrator/components/com_autotweet/helpers/autotweetroutehelper.php
components/com_autotweet/autotweetsefrouter.php

The routehelper calls from the admin area to the frontend sefrouter to get the SEF Url.

2. Ok, with this method, from the admin area, it creates a new Site App to get the SEF Url. It's not so compatible, since you are having two Joomla Apps interacting in the backend.

Regards,
  • Support Team
  • Support Team's Avatar
  • OFFLINE
  • Moderator
  • Posts: 1184
  • Thank you received: 95
  • Karma: 14
The administrator has disabled public write access.

ATNG: SEF URL only after second attempt 1 year 5 months ago #5928

Hi,

Thank you for tip!

I've added in administrator/components/com_autotweet/helpers/autotweetroutehelper.php 2 lines:
curl_setopt($c, CURLOPT_SSL_VERIFYPEER, false);
curl_setopt($c, CURLOPT_SSL_VERIFYHOST, false);

Left autotweetsefrouter.php as is since I don't see in it any CURL related code - there is simple call for JRoute in line 38.

Set back Routing Mode = Compatibility

Results positive: today I have stable SEF URL without any errors in log. :)

Just one more question. Is it true that if for any reason my Facebook APP will be deleted, all posts at FB will disappear? Is it FB's "by design" for any automated posts?
And looks like all images in posts have full URL to my site, so if any image will be renamed or moved, it'll disappear from Facebook?

Regards,
  • Meta Wind
  • Meta Wind's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 5
  • Karma: 0
The administrator has disabled public write access.

ATNG: SEF URL only after second attempt 1 year 5 months ago #5929

Yes, Facebook keeps a relation between an App and all associated assets (automated or not, it's the same for every Facebook object).

If the App is unpublished (several cases), all related assets are unpublished.

No, Images are loaded in Facebook's CDN. Example: fbstatic-a.akamaihd.net/rsrc.php/v2/y4/r/-PAXP-deijE.gif
  • Support Team
  • Support Team's Avatar
  • OFFLINE
  • Moderator
  • Posts: 1184
  • Thank you received: 95
  • Karma: 14
The administrator has disabled public write access.
Time to create page: 0.151 seconds

Prices shown without VAT. VAT will be charged to residents or businesses located in the European Union unless a VIES-registered VAT number is supplied in accordance to European Directive 2008/8/EU and its incorporation into EU member states' local laws.

For more information, http://www.fastspring.com/vat.php