Looking for Customer Service & Support

IMPORTANT: This is a Community Forum. Answers are given by the community. If you are a Customer, please, Open New Issue to get access to the support service.

Customer Support is only provided through our ticketing system https://support.extly.com/. If you do not have a paid membership, please create a new topic in the community forum.

2 sites, 2 channels, neither connecting properly

More
4 years 5 months ago #6420 by Bunglehaze
Bunglehaze created the topic: 2 sites, 2 channels, neither connecting properly
Hi guys, again I am back here looking for advice as I am still unable to make the free component work. I am trying it on two seperate sites and am having no luck on either.

First of all on one of them. I have setup the Facebook page, entered all the details for the app ID and secret, the canvas page etc and then on the FB app itself the canvas page URL has been setup using both a direct /fbtweet directory that I uploaded the facebook auth app files into as well as a menu link as described in the barely understandable documentation - neither setup works at all.

All I ever get when trying to authorise the app is: The redirect_uri URL must be absolute

Now on to site number 2, I have all the same details, even down to the name of the directory I uploaded the facebook auth app to the same directory and on this occasion I click authorise and I get the apps.facebook.com/bikechatter page loading but completely white in the section I would expect to see the authorisation dialogue - I am confused....

The first site is on an SSL connection and the intention is to get the articles function working and then upgrade potentially to the Pro version to have the VM products published too but I am getting fed up with trying to configure something with basic settings - yes App ID, Secret and canvas page are as basic as they need to be - so why on earth is it complaining about the uri?

All I can assume is that the facebook auth app is not working correctly somehow but I am not really sure where to begin. Once that one is figured I will move onto the Bikechatter app and see why that isnt showing anything - very frustrating

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #6422 by Support Team
Support Team replied the topic: 2 sites, 2 channels, neither connecting properly
Your app apps.facebook.com/bikechatter/ is not working.

Prerequisites for a Facebook App
  • AutoTweetNG Free (*) or PRO v6
  • A Facebook account
  • A site with SSL support

Please, remember that Facebook Apps must be hosted in a SSL-enabled host. A SSL certificate must be purchased (like a domain name), and installed in your hosting (check with your hosting provider).

Facebook also offers a free option, based in Heroku hosting (but you need to know GIT protocol). You can also use an inexpensive SSL certificate

How to AutoTweet from Your Own Facebook App
www.extly.com/how-to-autotweet-from-your...tml#/how-to-facebook

How to AutoTweet from Facebook-Heroku
www.extly.com/how-to-autotweet-from-your...tml#/how-to-facebook


Please, let us know if you have any further question.


Thanks,

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #6426 by Bunglehaze
Bunglehaze replied the topic: 2 sites, 2 channels, neither connecting properly
Hi there, the Bikechatter app is the second one I am trying to try and find the cause of the first one - as such there is no real need for it to work just yet. More problematic is the first site which is using SSL already:

I have setup the Facebook page, entered all the details for the app ID and secret, the canvas page etc and then on the FB app itself the canvas page URL has been setup using both a direct /fbtweet directory that I uploaded the facebook auth app files into as well as a menu link as described in the barely understandable documentation - neither setup works at all.

All I ever get when trying to authorise the app is: The redirect_uri URL must be absolute

There is nothing in the documentation that covers any of this.

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #6428 by Support Team
Support Team replied the topic: 2 sites, 2 channels, neither connecting properly
Hi,

The authoziration only submits the app data to the entered Canvas Page.

If there's a redirection error, it might be a problem in the entered Canvas Page or in the App configuration.

Which is the entered Canvas Page and the Secure Canvas URL?

Thanks,

Please Log in or Create an account to join the conversation.

Time to create page: 0.123 seconds
Join the Club!

Access and support services to all Extly's extensions for 1-Year. The Extly Club is your source for all of our extensions.

Join Now