Looking for Customer Service & Support

IMPORTANT: This is a Community Forum. Answers are given by the community. If you are a Customer, please, Open New Issue to get access to the support service.

Customer Support is only provided through our ticketing system https://support.extly.com/. If you do not have a paid membership, please create a new topic in the community forum.

Can't get the workaround for Joomla 1.5 to work

More
4 years 5 months ago #6446 by rienk Vlieger
rienk Vlieger created the topic: Can't get the workaround for Joomla 1.5 to work
Hi,

Still working on a a Joomla website 1.5 with Autotweet 4.12 (Joomla will be updated in the fall) I tried the workaround for a Twitter channel.
I installed AutoTweet on a test site, created the app incl. read&write application type, generated the tokens en validated them on the testsite (succes).
Then copied the tokens to the J1.5 site, saved the channel.
After this, the channel gives a 401

What I'm doing wrong?

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #6447 by staudi
staudi replied the topic: Can't get the workaround for Joomla 1.5 to work
Same Problem here, need help please!

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #6449 by Support Team
Support Team replied the topic: Can't get the workaround for Joomla 1.5 to work
Twitter has released a new API v1.1, and fully disabled the previous v1.0.

In practice, the Twitter API v1.0 Url is not available any more. So, you get the Twitter Http Error 410 Gone.

Checking the update:

Twitter API v1.0
		$code = $api->request(
				'POST',
				$api->url('1.0/statuses/update'),
				array('status' => $status_msg)
		);

Twitter API v1.1
		$code = $api->request(
				'POST',
				$api->url('1.1/statuses/update'),
				array('status' => $status_msg)
		);

At a basic level, if you replace all ocurrences of 1.0 with 1.1 in the Twitter API calls. It should work again.

Thanks,

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #6451 by staudi
staudi replied the topic: Can't get the workaround for Joomla 1.5 to work
I´ve found 2 API requests in /administrator/components/com_autotweet/helpers/channels
but they look different.
first:
'POST', 'https://upload.twitter.com/1/statuses/update_with_media.json',

second:
$code = $api->request('POST', $api->url('1/statuses/update'), array('status' => $status_msg));

there is a third, but it´s commented out.

Have tried to change the code to 1.1 but the error "401 Not Authorized ()" is already there...

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #6452 by Support Team
Support Team replied the topic: Can't get the workaround for Joomla 1.5 to work
If you have already changed /1/ with /1.1/, you might have also to update the underlaying library:

github.com/themattharris/tmhOAuth

Thanks,

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #6453 by staudi
staudi replied the topic: Can't get the workaround for Joomla 1.5 to work
I think thats not so easy.

the files and folders are different...

v 6.5.1
filename "twitter.php"
foldername "thmOAuth" with files "tmhOAuth.php", "thmUtilities.php", "cacert.pem" and "composer.json"

v 4.12
filename "autotweettwitter.php"
foldername "attwitter" with files "attmhOAuth.php" and "attmhUtilities.php"

i´ve tried a few things with renaming files and functions, but it still don´t work...

Please Log in or Create an account to join the conversation.

Time to create page: 0.103 seconds
Join the Club!

Access and support services to all Extly's extensions for 1-Year. The Extly Club is your source for all of our extensions.

Join Now