Looking for Customer Service & Support

IMPORTANT: This is a Community Forum. Answers are given by the community. If you are a Customer, please, Open New Issue to get access to the support service.

Customer Support is only provided through our ticketing system https://support.extly.com/. If you do not have a paid membership, please create a new topic in the community forum.

Can't get the workaround for Joomla 1.5 to work

More
4 years 5 months ago #6480 by rienk Vlieger
rienk Vlieger replied the topic: Can't get the workaround for Joomla 1.5 to work
Installed 4.12 pro version
changed in autotweettwitter.php:

'POST', 'Invalid consumer key/secret in configuration',
to
'POST', 'Invalid consumer key/secret in configuration',

and

$code = $api->request('POST', $api->url('1.1/statuses/update'), array('status' => $status_msg));
to
$code = $api->request('POST', $api->url('1/statuses/update'), array('status' => $status_msg));

Got new tokens from dev.twitter.com, application type: read and write
tested them in a 2.5 joomla testsite. (success)
copied the tokens to the 1.5 site, use own api: yes

result status: 410 Gone

Somebody an idea what's going wrong?

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #6481 by nugepcua
nugepcua replied the topic: Can't get the workaround for Joomla 1.5 to work
not sure how you test version 4.12 on Joomla 2.5 but anyway..

what's your version of autotweettwitter.php ?
(you can find it in the header of the file(commented out)
mine is 2.3.

if you got the same version I think you missed to update this line:
$code = $api->request('GET', $api->url('1.1/account/verify_credentials'));

double check the code once again
good luck

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #6482 by Rienk Vlieger
Rienk Vlieger replied the topic: Can't get the workaround for Joomla 1.5 to work
YES, that was it!

$code = $api->request('GET', $api->url('1/account/verify_credentials'));
change to
$code = $api->request('GET', $api->url('1.1/account/verify_credentials'));

in autotwittertweet.php (version 2.3)

By the way, I tested the API tokens in a Joomla 2.5 version with autotweet 6.5.1

Thanks for the support!

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #6484 by staudi
staudi replied the topic: Can't get the workaround for Joomla 1.5 to work
Ok, i have deleted the plugin and installed it again. changed "1" to "1.1" and now...

it works!

thanks to all!

Please Log in or Create an account to join the conversation.

Time to create page: 0.124 seconds
Join the Club!

Access and support services to all Extly's extensions for 1-Year. The Extly Club is your source for all of our extensions.

Join Now