Looking for Customer Service & Support

IMPORTANT: This is a Community Forum. Answers are given by the community. If you are a Customer, please, Open New Issue to get access to the support service.

Customer Support is only provided through our ticketing system https://support.extly.com/. If you do not have a paid membership, please create a new topic in the community forum.

AutotweetNG - Wrong url when posting article

More
1 year 5 months ago #10082 by krogias
krogias created the topic: AutotweetNG - Wrong url when posting article
Hi all,
When use AutotweetNG and I post an article, instead of redirecting to:
/administrator/index.php?option=com_content&view=articles
it redirects to:
/administrator/component/content/?view=articles
which gives error 403 - access forbidden!

In AutotweetNG Free (latest version) options I use:
Routing mode: Exmperimental (it's the only one that gives my the right SEF urls)
Enable URL routing: ON
Validate Url: No

I think it's a bug. Please Help!

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #10083 by Support Team
Support Team replied the topic: AutotweetNG - Wrong url when posting article
Hi,

Please, restore default options for SEF routing and try this FAQ: www.extly.com/docs/autotweetng_joocial/i...link-do-not-target-t

Regards,

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago - 1 year 5 months ago #10084 by krogias
krogias replied the topic: AutotweetNG - Wrong url when posting article
Thank you for your quick reply.
How do I reset the options for SEF?
I think, that the solution and the link you 've provided about "shortened URLs" is not my case.
My problem is that when I push the "publish" button to post a new article (in article manager) it doesn't return me to /administrator/index.php?option=com_content&view=articles but to a wrong url /administrator/component/content/?view=articles

SEF creates problems in the backend urls too?
Last Edit: 1 year 5 months ago by krogias.

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #10085 by Support Team
Support Team replied the topic: AutotweetNG - Wrong url when posting article
Hi,

The article shows the way to log how Urls are created.

These are the default values:

Routing mode =Compatibility mode
Enable URL routing=Yes
Validate Url =Yes

Please, enable the logging mode and test a case to generate xt-logging.log.

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago - 1 year 4 months ago #10091 by krogias
krogias replied the topic: AutotweetNG - Wrong url when posting article
With the above values I get the wrong url.
www.mydomain.com/index.php?option=com_co...42:dt&Itemid=292
instead of:
www.mydomain.com/enimerosi/nea/press/11443-test

and I get the following error:
Error routing SEF URL via frontend request - curl_error: 60 SSL certificate problem: unable to get local issuer certificate


Here is the log:

2016-07-21T08:21:54+00:00 INFO ........ - ValidateUrl: OK url = www.mydomain.com/
2016-07-21T08:21:54+00:00 INFO ........ - internal url = index.php?option=com_content&view=article&id=11443:test&catid=142:dt&Itemid=292
2016-07-21T08:21:54+00:00 INFO ........ - defineMultilingualTag: Url index.php?option=com_content&view=article&id=11443:test&catid=142:dt&Itemid=292
2016-07-21T08:21:54+00:00 INFO ........ - defineMultilingualTag: Lang-Url index.php?option=com_content&view=article&id=11443:test&catid=142:dt&Itemid=292
2016-07-21T08:21:54+00:00 INFO ........ - Calling SEF Router: www.mydomain.com/index.php?option=com_au...R0Jkl0ZW1pZD0yOTI%3D
2016-07-21T08:21:54+00:00 INFO ........ - --> result (0):
2016-07-21T08:21:54+00:00 INFO ........ - --> result Url:
2016-07-21T08:21:54+00:00 WARNING ........ - Error routing SEF URL via frontend request - curl_error: 60 SSL certificate problem: unable to get local issuer certificate
Last Edit: 1 year 4 months ago by krogias.

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #10092 by Support Team
Support Team replied the topic: AutotweetNG - Wrong url when posting article
Hi,

There is a misconfiguration in your SSL certificate and AutoTweet can't open a secure connection to route the SEF query.

You can check your certificate with: www.digicert.com/help/

Alternatively, you can ask to your hosting support to verify SSL configuration in your site.

Regards,

Please Log in or Create an account to join the conversation.

Time to create page: 0.134 seconds
Join the Club!

Access and support services to all Extly's extensions for 1-Year. The Extly Club is your source for all of our extensions.

Join Now