# Requirements and compatibility

In order to work, XTDir for SobiPro (opens new window) requires the following server software environment:

  • Joomla 3.9, or superior.

  • PHP 7.4, PHP 8, or superior.

  • SobiPro 1.3+, or superior

  • MySQL 5.7+, or superior (recommended).

  • PHP memory_limit 64 M, or more (recommended).

INFO

XTDir keeps backwards compatibility with previous SobiPro versions. Please, remember to verify SobiPro requirements here: https://www.sigsiu.net/center/sobipro-component/98-requirements (opens new window).

From Sigsiu's Archive (opens new window): Please note: NO SUPPORT is given for older versions of SobiPro: SobiPro 1.2, 1.1 and 1.0.