Requirements and compatibility

In order to work, AutoTweet requires the following server software environment:

  • Joomla! 3+, or superior - Please download the latest version at Joomla!.
  • PHP 5.5.9 +, or superior - General-purpose server-side scripting language for web development and a popular open source database system.
  • MySQL 5.5+, or superior (recommended).
  • PHP memory_limit 64 M, or more (recommended).
  • cURL PHP module must be enabled, with SSL support.
  • Server Timestamp must be updated for OAuth message authentication.
  • JSON PHP module must be enabled.
  • HMAC PHP module for keyed-hash message authentication must be enabled.
  • No PECL OAuth. PECL OAuth native extension must NOT be installed. Social PHP Libraries implement their own OAuth support.
  • Tidy HTML PHP module is recommended for feeds. Tidy HTML is a clean and repair utility which allows you to clean and manipulate HTML documents.

AutoTweet and Joocial 8.7.0 are the first versions to raise the minimum PHP version to PHP 5.4 or greater. More information: Facebook Developer Alert: Graph API v2.0 is reaching the end.

AutoTweet and Joocial 8.6.0 are the last versions compatible with PHP 5.3.10.

AutoTweet and Joocial 7.9.7 are the last versions compatible with Joomla! 2.5.28. They are available for download, but we do not longer offer active support (no more new features, enhancements and bug fixes for Joomla! 2.5). If you have an issue, please, send us a ticket and we will try our best to answer your questions. Keep in mind that every day your alternatives are closing down. Joomla! 2.5 is not longer supported by Joomla! community (end-of-life December 31, 2014) and JED removed J25 extensions on June 30, 2015 . It is highly recommended to upgrade to Joomla! 3 as soon as possible.